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1.0 Stream Condition Definition 

 
When defining a stream condition the Gibbs phase rule applies. The variables that define a 
process condition are in two categories:- 
 
Extensive variables  Mol, Mass, Volume 
Intensive variables  Temperature, Pressure, Density, Specific Volume,  
   Mass and Mol Fraction of Components i. 
 
The number of intensive variables that can be independently specified for a system at 
equilibrium is called the number of degrees of freedom F and is defined by the Gibbs Phase 
Rule. In a system involving no reactions this is given by: 
 

pm2F −+=  

  
Where       m     =       no of chemical species i                p      =       number of system phases 
 
Where   r    we have  independent reactions at equilibrium  
 

prm2F −−+=  

 
Considering a single component liquid in equilibrium with its vapour and an inert gives:-   
 

m = p = F = 2 
 
Two variables  P  and  T  or Vapour Fraction with T  or  P  will define the stream. 
 
For a binary liquid system one degree of freedom is consumed by the composition leaving either 
P or T to be specified. In a VLE system it is preferable to specify P which then allows  system 
analysis using  Txy plots. 
 
When setting up the Flash UnitOp applying the phase rule will ensure that the relevant flash 
conditions are being set. 
 
Setting any two parameters from the variables temperature, pressure, enthalpy or V/F will define 
the flash condition. 
 
The stream flash calculation can be used to determine the boiling point and dew point of 
mixtures with and without inerts present. The bubble point of a liquid at the given pressure is 
determined by a flash calculation at a vapour fraction of 0. The dew point of a vapour at the 
given pressure is determined by a flash calculation at a vapour fraction of 1. For a pure 
component the bubble point and the dew point are identical so a flash calculation at a vapour 
fraction of  0 or 1 will yield the same result. 
 
The Txy diagram for Benzene/Toluene, a near ideal mixture, is shown later. The bubble point for 
a given composition is read directly from the liquid curve and the dew point is read directly from 
the vapour curve. 
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1.0 Stream Condition Definition (Cont.) 

 

Table Presenting Molar and Mass Relationships for Mixture with “i” Species 

Component MW % 
v/v 

Volume in 
1 m3 

Mass in 
1 m3 % w/w Mass Flow Molar 

Flow % 
mol kg/kmol m3/m3 kg/m3 kg/h kmol/h 

A MA  PA  
100VA = PA  

2240
MP AA  

∑ MP ii

MP100 AA  
∑ MP ii

MPW AA  
∑ MP ii

PW A  PA  

B MB  PB  
100VB =
PB  

2240
MP BB  

∑ MP ii

MP100 BB  
∑ MP ii

MPW BB  
∑ MP ii

PW B  PB  

C MC PC  
100
PV C

C =  
2240

MP CC  
∑ MP

MP100

ii

CC  
∑ MP

MPW

ii

CC  
∑ MP ii

PW C
PC  

Total  100 1 
2240

MP ii∑  100 W 
∑ MP

W100

ii
 100 

 Acknowledgements to the late Doug Lindsley for this format. 
 

 
We have the following definitions, noting that each mol occupies the same volume ie  
mol% = vol % 

Total Flow       (kg/h)        W                                         Density of mixture     (kg/m3)    
2240GO =

M
__

 

               Total Flow       (Nm3/h)    
∑ MPG iiO

==
W2240W

Q      Average MW    (kg/kmol)   
100

MPM ii
__ ∑=
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2.0 Flash Process Fundamentals 
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2.0 Flash Process Fundamentals (Cont.) 
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3.0 Bubble and Dew Point Process Fundamentals 
 

 
 



CHEMCAD 6.0  Process Fundamentals and Basic Navigation 
 

 
  P & I Design Ltd                                                                                                                 MNL501A  06/08 
  2 Reed Street, Thornaby, UK, TS17 7AF PAGE 8 OF 22 
  Tel: + 44 (0)1642 617444  
  Fax: + 44 (0)1642 616447 
 www.pidesign.co.uk 

3.0 Bubble and Dew Point Process Fundamentals (Cont.) 
 

 
 
 



CHEMCAD 6.0  Process Fundamentals and Basic Navigation 
 

 
  P & I Design Ltd                                                                                                                 MNL501A  06/08 
  2 Reed Street, Thornaby, UK, TS17 7AF PAGE 9 OF 22 
  Tel: + 44 (0)1642 617444  
  Fax: + 44 (0)1642 616447 
 www.pidesign.co.uk 

3.0 Bubble and Dew Point Process Fundamentals (Cont.) 
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3.0 Bubble and Dew Point Process Fundamentals (Cont.) 
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MENU BAR COMMANDS 
 
The main menu bar gives access to all the commands required to drive CHEMCAD. 
The main menu bar is as shown below: 
 
 
 
 
Commands available on the File menu are 
 

 
 
A useful feature worth noting is that any of the recent simulations listed above Exit can be opened directly from here which 
is very useful if working between several simulations. 
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MENU BAR COMMANDS 
 
Commands available on the Edit menu are 
 

 
 
 
Commands available on the View menu are 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The Refresh Data Boxes command updates the contents of all data boxes in the simulation. Select this command after 
running the simulation to ensure that the data boxes display the current results. 
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MENU BAR COMMANDS 
 
Commands available on the Format menu are 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This is where you set up the engineering units for the simulation. You can also customise the look of the text, lines, and 
shapes that you use on the flowsheet. The Import Bitmap command enables you to add a logo or other image to your 
flowsheet, and the bottom section of this menu includes commands for adding various types of data boxes. 
 
Commands available on the Thermophysical menu are 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Refer to User Added Components later for more on this menu. 
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MENU BAR COMMANDS 
 
Commands available on the Specifications menu are 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Commands available on the Run menu are 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The simulation conditions are set here. This covers calculation sequence methods, steady state or dynamic convergence 
method, and recycle tolerances. 
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MENU BAR COMMANDS 
 
Commands available on the Report menu are 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Commands available on the Plot menu are 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Each plot that you create resides in a tabbed window that you can leave open until you close the simulation. You can 
customise each open plot and transfer plot data directly to Excel. The menu shown here is for a simulation running in 
dynamic mode, as the Dynamic Plots menu item is not shadowed. 
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MENU BAR COMMANDS 
 
Commands available on the Sizing menu are 
 
 
 
 
 
 
 
 
 
 
 
 
The sizing facility allows you to size flowsheet pipes, valves, and orifice plates using the model stream data for the stream 
selected.  Relief devices are sized using stream data, but caution must be used to ensure conditions are applicable to the relief 
condition being studied. 
 
Commands available on the Tools menu are 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Units Calculator is available using function key F6. 
Excel Data Mapping provides a powerful feature for transferring data between the CHEMCAD model and Excel. This 
feature can be used for customising reports or enhancing modelling capabilities. 
The Options menu gives access to the license parameters. 
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MENU BAR COMMANDS 
 
Commands available on the Window menu are 
 
 
 
 
 
 
 
 
 
 
 
 
 
Commands available on the Help menu are 
 
 
 
 
 
 
 
 
 
 
 
Coach provides the new user with a simple to follow introduction to CHEMCAD. 
 
 
 
FUNCTION KEYS 
F1 Opens CHEMCAD Help 
F6 Opens units calculator; if in a data entry field with specified units, opens at applicable units calculator 
F7 Opens simple calculator
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USING THE TOOLBAR BUTTONS 
 
The toolbar shortcut buttons are shown below with a brief description. 

 
 1  2 3  4 5 6  7 8 9 10  11 12  13 14  15 16 17  18  19 20  21 22  23 24 25 26  27  28 29 

File control buttons 

 
1 New: Opens a window to begin a new simulation 
2 Open: Opens an existing simulation 
3 Save: Saves the currently open simulation 
4 Print: Prints (or plots) the current display or output 
5 About: Indicates CHEMCAD version 

Editing buttons  

 
6 Cut: Removes selected portions of the flowsheet and copies them to clipboard 
7 Copy: Copies selected portions of the flowsheet to the clipboard 
8 Paste: Pastes portions of a flowsheet or symbol from the clipboard 

View control buttons  

 
9 Zoom percentage: Selects the percentage to be used when zooming in and out 
10 Zoom in:  Zooms in a specified percentage on the centre of the flowsheet 
11 Zoom out:  Zooms out a specified percentage from the centre of the flowsheet 
12 Zoom to fit:  Zooms to fit flowsheet to screen 
13 Zoom in at a point: Zooms in a specified percentage on a user-specified point of the flowsheet 
14 Zoom out at a point: Zooms out a specified percentage on a user-specified point of the flowsheet 
15 Zoom rectangle:  Zooms in on an area of the flowsheet indicated by a user-drawn rectangle 
16 Pan overview:  Opens and closes the Pan Overview window allowing user to pan the flowsheet 

Flowsheet preparation and specification buttons 

 
17 Select Components: Opens component database to allow component selection 
18 Thermodynamic Settings: Allows selection of K-Value, Enthalpy Value and Transport Properties 
19 Edit Feed Streams: Allows change of feed stream parameters 

Simulation control buttons 

 
20 Run All:   Runs a steady state simulation 
21 Set Run Time:  Allows selection of "simulated time" and integration time steps for a dynamic simulation 
22 Reset to Initial State: Resets a dynamic simulation to the initial state (time zero) 
23 Run dynamic simulation: Starts a dynamic simulation from the initial state (time zero) 
24 Plot Dynamic Streams: Plots results of a dynamic simulation for specified Streams 
25 Plot Dynamic UnitOps: Plots results of a dynamic simulation for specified UnitOps 
26 View all stream compositions 
27 View all stream properties 

Components and results view buttons 

 
28 Component List:  Displays a list of the components currently selected for this flowsheet 
29 Flowsheet Quickview: Allows streams and UnitOps quick view by pointing with mouse 
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FILE TYPES and HANDLING 
 
Types of files: Simulation files  .CC6 

User component files .PPDB (for user-added components) 
User symbols (icons) .SYM 

  Export formats  .DXF, .XML 
 
WHERE SIMULATION FILES ARE STORED 
 
During installation, a directory is created in My Documents called My Simulations. Users can create their own subdirectories 
within the My Simulations directory. 
 
SAVE AS COMMAND 
 
The Save As command makes a copy of the current simulation and saves it under a new name in a user-specified directory 
(normally the current directory). The Save As command is located on the File menu. 
 
USER-ADDED COMPONENTS 
 
CHEMCAD allows you to add any number of components to the component database. This permits you to save data for 
compounds that are not in the database, or to change individual properties for some of the standard components. Additional 
components can be created in user component databases, which can be shared among multiple CHEMCAD users. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ADDING NEW COMPONENTS 
 
You can define new component properties in one of several ways. 
 

• Estimate from correlations suited for hydrocarbon pseudocomponents 
• Estimate using the modified Lydersen method (Joback or UNIFAC) 
• Estimate using a combustion solid correlation 
• Define an electrolyte 

 
Group Contribution Correlation 
 
The modified Lydersen method estimates the physical properties of individual components from their molecular weight and 
molecular structure. It may be used to estimate properties for all kinds of compounds, whether they are hydrocarbon, 
chemical, polar or non-polar.  It is necessary that the functional groups in the molecule be in the CHEMCAD database. 
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The required input is the molecular weight and the compound molecular structure. It is recommended that you input the 
normal boiling point and specific gravity. This method can estimate these two properties, but other properties generated by 
the program will be more accurate if you can supply them.   
 
After invoking the Create New Component command, follow this procedure to create a new compound. 
 
Example:  Ethyl Alcohol is composed of 1 Methyl group (-CH3), 1 Methylene (>CH2) group, and 1 hydroxy group (-OH).   

 
1. Enter a name for the component and any optional entries such as boiling point, specific gravity, and API gravity. For 

our example, select the correlation method called Group contribution – Joback. Click OK. 
 
2. Fill out the Group Assignments dialog box to include all the functional groups and quantities of each group found in 

this molecule. Note that there are hydrocarbon groups listed for both ring and straight chain molecules. Click OK. 
 
3. Use the View/Edit Component Data menu to review data generated by the program and to change estimated 

data with any available experimental values. 
 
Pseudocomponent Correlation 
 
This method is used primarily for hydrocarbons in the form of lumped components. The method is empirical and requires 
only a minimal amount of information to generate reasonable properties for fractions. 
 
You can use this method for estimating properties for a pure component, or for pseudocomponents that may be constituents 
of pure hydrocarbon mixtures. 
 
Only the average boiling point and specific gravity of the mixture are required input.   
 
Follow this procedure after selecting Create New Component from the menu. 
 
1. Select Pseudocomponent and click OK. 
 
2. Enter the component name, normal boiling point, and either the specific gravity or API gravity.  
 
3. Choose the correlation for estimating molecular weight. Select from: 
  Chemstations  (default) 
  New API 

Old API 
  Lee Kesler 
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4. Choose the Critical Properties Method. Select from: 
  Cavett  (default) 
  API  
  Lee Kesler 
5. Click OK to save data and the program will generate the properties and automatically call up the View/Edit 

Component Data menu. 
 
6. Use the View/Edit Component Data menu to review data generated by the program and to change estimated data 

with any available experimental values. 
 
Combustion Solid Correlation 
 
This correlation estimates the physical properties of coal combustion solid components. The required input is the name of the 
component and the solid element analysis by weight percentage or stoichiometrics. You can optionally provide the net heat 
value, gross heating value, or solid heat capacity. If you do not provide a heating value, CHEMCAD calculates it based on 
the component molecular weight. 
 
Electrolyte Correlation 
 
The correlation is meant to be used for the creation of an electrolyte component. It is recommended that you supply the 
electrolyte state, electrolyte type, molecular weight, electrolyte charge, heat of formation, standard Gibbs of formation, 
entropy, and heat capacity for the component. 
 
Note: The minimum data required to use a pure component in a simulation includes name, molecular weight, critical 
temperature, critical pressure, specific gravity, accentric factor, and the coefficients for the ideal gas heat capacity. Some of 
these values will be estimated by CHEMCAD. Electrolytes and solids have different requirements. 
 
EDITING COMPONENTS 
 
View/Edit Component 
 
Use this command to edit user-added components directly. To edit a standard component, you must first use the Clone  
Component command to create a user (editable) component. 
 
Clone Component 
 
The Clone Component command calls up the Select Single Component dialog box, where you can choose a component to be 
copied. The component to be cloned may be either a standard component or one that you defined previously. 
 
Delete Component(s) 
 
This command erases a component from the list of user-defined components. When you select this option, the program will 
give you a list of the user-added components in the database. It will not present you with ALL the components in the 
database, as you are not allowed to erase components from the CHEMCAD database. 
 
You can select a component by formula or by typing in its synonym (if available). To select multiple components for deletion 
at the same time, hold down the [CTRL] key as you click to highlight each component to be deleted. When you have selected 
the desired component(s), click Delete to remove your selection(s) from the user-added component database. 
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